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Warranty and Service Policy

Product Warranty

DATAQ Instruments, Inc. warrants that this hardware will be free from defects in materials and workmanship under
normal use and service for a period of 1 year from the date of shipment. DATAQ Instruments' obligations under this
warranty shall not arise until the defective material is shipped freight prepaid to DATAQ Instruments. The only
responsibility of DATAQ Instruments under this warranty is to repair or replace, at its discretion and on a free of
charge basis, the defective material.

This warranty does not extend to products that have been repaired or altered by persons other than DATAQ Instru-
ments employees, or products that have been subjected to misuse, neglect, improper installation, or accident.

DATAQ Instruments shall have no liability for incidental or consequential damages of any kind arising out of the
sale, installation, or use of its products.

Service Policy

1. All products returned to DATAQ Instruments for service, regardless of warranty status, must be on a freight-pre-
paid basis.

2. DATAQ Instruments will repair or replace any defective product within 5 days of its receipt.

3. For in-warranty repairs, DATAQ Instruments will return repaired items to the buyer freight prepaid. Out of war-
ranty repairs will be returned with freight prepaid and added to the service invoice.
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1. Introduction

This manual contains information designed to familiarize you with the features and functions of the DI-4108 and DI-
4208 USB and Ethernet data acquisition systems.These systems are identical excluding gain ranges.

Features

Both the DI-4108M and DI-4208M data acquisition instruments are portable data recording modules that communi-
cate through your computer's USB and/or Ethernet port with stand-alone capability. Features include:

» 8 fixed differential analog inputs protected to 100 Vfor 4108 and 120V rms for 4208

*  USB, Ethernet, and Power over Ethernet (PoE) interface options.

» 7 digital ports protected to +25V.

*  Up to 16-bit measurement resolution (dependent on sample rate).

*  The DI-4108 has programmable measurement ranges of +200, £500 mV, +1, 2, +£5, £10 Volts.
*  The DI-4208 has programmable measurement ranges of 2, +5, £10, £20, +50, £100 Volts.
*  Up to 160 kHz maximum throughput sampling rate.

*  Adaptable low-pass filter per channel - corner frequency set as a function of sampling rate
* A multi-purpose push-button for WINDAQ remote events and start/stop recording.

*  Multi-color LED indication for easy notification of device status.

*  Free WinDaq data acquisition recording software.

»  Stand-alone option allows the user to configure a recording session through their PC then record data in the field
to removable flash memory via the USB drive port (without being connected to their PC). Stand-alone data log-
ging requires Unlock code to record more than 1 channel to removable flash memory.

*  Counter channel.
*  Frequency channel.

¢ ChannelStretch™ Technology allows you to sync up to 16 DI-4730, -4108, or -4208 instruments in any combina-
tion with a total throughput of 480kHz or more (requires unlock code for each device).*

*  Fully documented instrument protocol for programming the device in operating systems other than Windows.*

*WinDaq/Unlock required per device to use ChannelStretch™ and to record more than four total channels when
using WinDagq software. These restrictions do not apply when programming the device yourself.

Analog Inputs

Both the DI-4108 and DI-4208 feature eight differential channel inputs located on a single sixteen-position screw ter-
minal block for easy connection and operation. Gain measurement ranges of +200, £500 mV, +1, 2, +5, 10 Volts
for the DI-4108 or +2, +5, 10, +20, £50, =100 Volts for the DI-4208 are programmable on a per channel basis. Ana-
log channels are protected to 100 V.

Utilize the functionality of WINDAQ software to experience all the features encased in these small, inexpensive
instruments. An Unlock Code is required to record more than four channels of any type on either device or to syn-
chronize multiple units when using WinDagq software. There are no restrictions when programming the instruments
yourself.

Introduction
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Digital 1/0

The DI-4208 contains seven digital ports, which may be used as a general-purpose digital input or for a specific func-
tion as designated on the device. Digital port DO may be used for WinDaq Events; Digital port D1 may be used for
WinDaq remote Start/Stop; Digital port D2 may be used for rate measurements; Digital port D3 may be used for
counts; Digital ports D4 and D5 are general purpose digital input ports. Please Note: Digital outputs are not supported
in WinDaq software. Each port may be configured as a switch using the provided protocol

Software

All software required to record and playback waveforms is included with the purchase of any DI-4108 or 4208 data
acquisition system via download. Use the WinDaq Dashboard to access WinDaq Acquisition software or to setup the
stand-alone configuration.

WinDAQ® Recording and Playback Software

WINDAQ Acquisition and WINDAQ Waveform Browser allow you to record and playback data acquired through your
instrument. WINDAQ software is an invaluable resource to record and analyze your data and is available for free from
our web site (www.dataq.com).

WINDAQ Lite Data Acquisition software (free) can be used to record waveforms directly and continuously to disk
while monitoring a real time display of the waveforms on-screen. An optional unlock code is available to allow you
to sync multiple units.

WINDAQ Waveform Browser playback software (also known as “WWB?”) offers an easy way to review and analyze
acquired waveforms. A built-in data file translator allows the user to display multiple waveforms acquired by
WINDAQ Acquisition software or any of a wide range of data acquisition packages. The software’s disk-streaming
design allows data files of any length to be graphically displayed rapidly, in normal or reverse time directions. Seven
standard cursor-based measurements, frequency domain, and statistical analysis functions help simplify waveform
analysis and interpretation. WINDAQ Waveform Browser is free and installed when installing WINDAQ Software.

Help
All WINDAQ software utilizes online help.

Introduction
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2. Specifications

Analog Inputs
Number of Channels:
Channel Configuration:

Measurement range per channel:
Input impedance:

Absolute accuracy:

Absolute maximum input without damage:

Maximum common mode voltage:
Common mode range:
Common mode rejection ratio:

Channel-to-channel crosstalk rejection:

ADC Characteristics

Resolution:

Max. throughput sample rate:
Min. throughput sample rate:

Sample rate timing accuracy:

Digital Ports
Number of Ports:
Type:
Configuration:
Threshold levels

Absolute maximum applied voltage (V):

Reserved Digital Inputs
Port 1:
Port 2:
Port 3:
Port 4:

Count/Rate/Digital Inputs

Internal pull-up value:

8
Differential

DI-4108: Programmable +200, £500 mV, +1, +2, +5, £10 V
DI-4208: Programmable +2, +5, 10, £20, +50, £100 V

DI-4108: 100 kQ differential
DI-4208: 795 kQ differential

0.25% of full scale range @ 25°C, excluding common mode error

120 V rms (normal mode + common mode) for DI-4208
100 V for DI-4108

+10 V dc or peak ac
50 dB (dc - 60 Hz)
-80 dB

12- to 16-bit
Above zero ADC counts: 2,047 to 32,767
Below zero ADC counts: 2,048 to 32,768

Standard: 160 kHz
Stand-alone: 20 kHz to 160 kHz (dependent on flash memory)

Standard: 20 Hz (2.2 samples per hour with WinDaq)
Stand-alone: 0.0017 Hz

100 ppm

7

MOSFET switch

Programmable as digital input or switch
TTL compatible

25V dc

WINDAQ remote events
WINDAQ remote start/stop
Rate input

Count input

4.7kQ

Specifications
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Input high voltage threshold:
Input low voltage threshold:
Terminal count:

Maximum rate frequency:

Minimum rate frequency:

Maximum count frequency:

24V
08V
65,535

50 KHz with one enabled channel
20 KHz with 2-4 enabled channels
10 KHz with 5-7 enabled channels

0.5Hz
50 kHz

Digital Ports Programmed as Switch

Maximum drain voltage:

Maximum sink current:

Ethernet Interface
Type:

Connector:
Protocol:

Server Type:

Removable Memory
Type:

Required Format:

Number of Channels:

Indicators and Connections
USB Interface:
Button:

USB A Connector (Drive):

Input connections:
Status LED:

25V
100 mA

10/100Base-T
RJ-45

TCP/IP

DHCEP or Fixed IP

MLC, pSLC, or SLC flash memory (with USB SD card reader); USB

thumb drive
FAT32

1; Unlock code required for 2 or more

USB 2.0 (mini-B style connector)

Multi-function control (Start, Stop, Save Configuration, Apply Configu-

ration)

USB drive for Stand-alone data logging

Cannot be used concurrently with the USB interface

Two 16-position screw terminal strips

One multicolor LED for status indication

USB ChannelStretch™ Operation

Total Max Units:
Max Channel Count:
Max Throughput:

Channel skew between any 2 units:

16
128 Analog, 112 Digital

>480 kHz (higher speeds may result in data loss)

10 uS, typical

Specifications
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Synchronization Conditions:

Syncs with any combination of DI-4730, DI-4108, DI-4208, and DI-
4718B USB instruments.

All synced instruments must operate at the same sample rate per channel,
regardless of channel number, type, or range.

All instruments must be connected to the same USB controller. The use
of USB hubs are recommended to meet this requirement.

Ethernet ChannelStretch™ Operation

Total Max Units:

Max Channel Count:

Max Throughput:

Channel skew between any 2 units:

Synchronization Conditions:

Power

Power Consumption:

Environmental
Operating Temperature:
Operating Humidity:
Storage Temperature:

Storage Humidity:
Physical Characteristics

Enclosure:

Mounting:
Dimensions:
Weight:

Software Support

WINDAQ software:

Programming:

16

128 Analog, 112 Digital

>50 kHz (higher speeds may result in data loss)
100 pS, typical

Syncs with any combination of DI-4730, DI-4108, DI-4208, and DI-
4718B Ethernet instruments.

For most accurate synchronization, all instruments should be connected
to the same Ethernet switch.

<1.0 Watt, via USB interface

0°C to 50°C (32°F to 122°F)
0 to 90% non-condensing
-20°C to 60°C (-4°F to 140°F)

0 to 90% non-condensing

Hardened plastic (Standard)
or
Aluminum based with Steel wrap-around with plastic bezels (M version)

Desktop; bulkhead

6.68D x 3.28W x 1.13H in. (Standard)
or
5.44D x 4.13W x 1.5H in (M version)

5.7 0z. (162 grams) or 14 oz (M version)

OS support: Check online at http://www.dataq.com/products/windaq/
windows-compatability/

Instrument Protocol

Specifications
5






DI-4108M and DI-4208M Hardware Manual

3. Installation

The following items are included with each DI-4108 or DI-4208 Data Acquisition System. Verify that you have the
following:

* A DI-4108 or DI-4208 data acquisition instrument.

*  6-foot USB cable; Ethernet versions also provide a 5-foot Ethernet cable and an AC power supply if required
(PoE versions do not come with a power supply).

* A DATAQ Instruments screwdriver for signal lead connections.
* A USB flash drive with WinDaq software. Can also be used for stand-alone data logging.

If an item is missing or damaged, call DATAQ Instruments at 330-668-1444. We will guide you through the appropri-
ate steps for replacing missing or damaged items. Save the original packing material in the unlikely event that your
unit must, for any reason, be sent back to DATAQ Instruments.

Install WINDAQ Software

All software for the DI-4108 and DI4208 can be installed via a download-able executable directly from the DATAQ
Instruments web site. The software is also available on the provided USB flash drive.

1. Disconnect all DATAQ Instruments USB devices from your Computer.

2. Plug the USB flash drive into your computer’s USB port or go to http://run.dataq.com to download the software.
3. Save the executable (Dataq Software Suite Web Setup.exe) to your local hard drive.
4. Double-click on the executable to extract the program and begin software installation.

5. Follow the on-screen prompts and enter all required information.

Installation
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6. Software installation is complete - you will now see a “Successful Installation” box - click OK to exit WINDAQ
Installation.

You can now plug the device(s) into your PC. Click on the appropriate program group (specified above — default is
Start > Programs > WINDAQ) and click on “WinDaq Dashboard” to access WINDAQ software.

Connect the Instrument to Your Computer

All DI-4108 and DI-4208 instruments can be connected to your computer’s USB port using the provided USB cable.
No external power is required when connected via the USB port. Connect one end of the communications cable to the
instrument port and the other to your PC’s port. Ethernet devices are equipped with a USB port and can be used as a
USB device. Open the WinDaq Dashboard to run WinDaq Data Acquisition software, set the device clock, and con-

figure and record data to a thumb drive.

Note: Use a powered USB hub or a USB port on your PC. Non-powered USB hubs may not have sufficient power to
run the instrument.

Install an Ethernet Device on Your Local Area Network

All Ethernet instruments are shipped DHCP-enabled. We recommend you setup a DHCP reservation on your network
for your data acquisition applications.

1. Find the MAC address of your DI-4x08. The device MAC address is printed on the bottom label of the device:

atier MAC: 001B81000232
_ D7 O M N Y .

R e

wwe Ta'as e
2. Login to your Router and ensure the DHCP server is enabled.
3.  Access the DHCP Reservations, Static DHCP, or IP Allocations page/table.

4. Enter the MAC address of your device in the table (you may need to enter colons for proper format - for example,
001B1000232 may need to be 00:1B:81:00:02:32), enter an unused IP address in the table row (or allow your
router to select it for you if possible), and Select/Enable for DHCP Reservation.

5. Save your router settings.
6. Connect your DI-4x08 unit into your Local Area Network using the supplied Ethernet Cable.
7. Apply Power to the device if required. PoE devices can derive power from a PoE switch.

Open the WinDaq Dashboard utility to access device settings and run WinDaq Data Acquisition software. The
WinDaq Dashboard allows you to set the device clock, change your Ethernet settings (DHCP/Static), setup and
record to a thumb drive, access files on the thumb drive, and view live data.

If your device is not discovered in WinDaq Dashboard, connect it to your computer via the USB cable and configure
the Ethernet settings to allow for DHCP.

If the device is available in WinDaq Dashboard but you cannot run WinDaq Acquisition software, you may have the
application blocked in Windows Firewall. See https://www.dataq.com/blog/data-acquisition-software/is-the-win-
dows-defender-firewall-blocking-windag/ for more information and resolution.

Installation
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4. Controls, Indicators, and

Connections

s

D

Connecting | Idle | Armed | Recording | Rearmed | Busy | Erro )
USB oe oe = [ X ] - - [ )
Ethernet e @O = [ 1®) - - [ ]
Drive ce @0 | @0 0 [ X' [ X ) o

Button
‘“mm%”’ O O
Drive Status
Ethernet USB (E
)

Mini-B USB Connection

Use the supplied USB cable to connect and power the instrument through your computer’s USB port or power supply

Screw Terminals

All input signal connections are made to the 16-port screw terminals. Each terminal is labeled on the instrument case.

A CAUTION A

Never touch exposed screw terminal connector pins or screws.

To avoid ESD damage in handling the device, take the following precautions:

Ground yourself with a grounding strap or by touching a grounded object before and during your handling of the
instrument.



DI-41/208M Signal Connections

Refer to the following for screw terminal port identification.

e CH1 CH2 CH3 CH4 CH5 (CH6 CH7 CHs mDATAQQ

INSTRUMENTS

D0 D1 D2 D3 D4 D5 D6 VOUT
2000418 R i ST S e e

Ch#: Analog channels 1-8

D#: Digital port (0-6). Can also be used for specific WINDAQ functions (+25 Vmax).
D0 Event — WINDAQ Remote Event Marker (or general-purpose)
D1 Record — WINDAQ Remote Start/Stop (or general-purpose)
D2 Rate — Rate Input (or general-purpose)
D3 Count — Counter Input (or general-purpose)
D4 ... D6 — General-purpose digital ports

Vout: +15V out. Max 1W.

DI-41/208M D37 Signal Connections

Refer to the following for screw terminal port identification.

/

IEDATAQ

INSTRUMENTS

SRR W o“
SSRGS o o

37-pin D sub cutout p

(LQ N ‘L %l ‘Lb‘ qga/q;\x(ﬁ:b(@ X,bQ ,%\X%{L/P’{bx'bb‘g@ o A\
200041810 FF NN 0“”0“’ PP NP PP RS

Ch#: Analog channels 1-8

D#: Digital port (0-6). Can also be used for specific WINDAQ functions (+25 Vmax).
D0 Event — WINDAQ Remote Event Marker (or general-purpose)
D1 Record — WINDAQ Remote Start/Stop (or general-purpose)
D2 Rate — Rate Input (or general-purpose)
D3 Count — Counter Input (or general-purpose)
D4 ... D6 — General-purpose digital ports

Vout: +15V Excitation Supply. Max 1W
AGnD: Analog Ground.



Analog Inputs

Eight differential analog inputs measure £200, +500 mV, £1, £2, £5, +10 Volts on the DI-4108or £2, £5, +10, £20,
+50, 100 Volts for the DI-4208 (CH1 to CHS, programmable per channel) . Designed to withstand 120 Vrms for DI-
4208M and 100V for DI-4108M.

AIN +

—_

0K

Specify a full scale range for the channel in the menu item Edit > Channel Settings.

Gain -FS Volt +F5 Volt ~Acguisition Method - Gain -FS Volt +F5 Volt —Acguisition Method -

1 -10.0000  10.0000 i 100.000  100.000 -

2 5.0000  5.0000 o [l 50.000  50.000 o e

5 2.00000  2.00000 £ Last Point 20.0000  20.0000 ¢ Last Point
-1.00000  1.00000 = 10.0000  10.0000
-.50000 50000 " Maximum -h.0000 5.0000 " Maximum
200000  .200000 2.00000  2.00000

" Minimum  Minimum
" BMS  BMS

" Frequency " Frequency

~Input Type ~Input Type

& Linear & Linear

" Monlinear ' Monlinear

" Thermocouple . ) " Thermocouple
[T Unipolar [~ Eahrenheit " Unipolar [C Eahrenheit

Reset EU | Cancel OK I Reset EU | Cancel
Previous | Next Previous |

DI-4108 Channel Settings DI-4208 Channel Settings




Scroll through all enabled channels with the Next and Previous buttons.

Low-pass Filter

Each analog channel employs a low-pass filter with automatic corner frequency selection. The filter is a CIC (cas-
caded integrator comb) type that uses as many as 512 samples per channel to calculate in real time as data is acquired.
Filter response is optimized when sampling frequency is set to ten times the highest frequency of interest.

Typical Low-pass Filter Frequency Response

-10
204
20

40+

Magnitude (dB)

50

e 3 01 02 032 04 -3:5 06 o7 -D:E 09 1
Normalized Frequency (fsignal / fsampling rate)

The DI-4108 and DI-4208 calculate its own Last Point, Maximum, Minimum, and Filter data making it available at

the programming level. Acquisition methods “RMS” and “Frequency” are permanently disabled for the DI-4108 and

DI-4208, as are Input Types “Nonlinear” and “Thermocouple” and selections for “Unipolar” and “Fahrenheit.”

Resolution as a Function of Sample Rate

The resolution of the DI-4108 and DI-4208 is a function of sample rate. The lower the sample rate the higher the res-
olution. ADC resolution (R) is a function of selected sample rate per channel (F), and the number of enabled analog
channels (C):

160000
'Og( FC )
R= +12
log(4)

C Enabled Channels

oo | KD
I
N




ADC Resolution vs Sample Rate
16.0 ¢

15.5 o

15.0 o

145 o

14.0 o

135 o

12.0
64 128 256 512 1024 2048 4096 8192 16334 32768 65336 131072

—e—1chn —e—2ch 3-4ch 5-8ch

Digital Ports

The DI-4108 and DI-4208 contain 7 general-purpose digital ports. Each digital port can be configured as a digital input
or used as a switch to control an external load (up to 25 V and 100 mA). Many of the ports also provide specific func-
tionality in WINDAQ or a third-party program.

DO Event is for WINDAQ Remote Events. This bit inserts an event marker in your data.

D1 Record is for WINDAQ Remote Storage. This bit can be programmed to begin recording data.
D2 Rate is for Rate measurements: 10Hz to 50kHz.

D3 Count is for Counter/Timer measurements up to 65,536.

D4 and D5 are general-purpose digital inputs.

D6 Ext Trig is for third-party external triggers.



Equivalent Digital I/O Circuit:

3.3V

5

Dx +

Control L ) Dx-

10Q

WINDAQ Remote Events (DO Event)
To use a switch closure or TTL signal to record WINDAQ Event Markers, connect signal leads to the appropriate
Remote Control Event terminals .

Once the switch closure or TTL signal is connected, activate Remote Events through WINDAQ Acquisition Software.
Events may be automatically placed on the rising or falling edge of the trigger signal. Use the menu command
Options > Remote Events + to set WINDAQ to place event markers on low-to-high transitions of the Event input.
Use the menu command Options > Remote Events - to set WINDAQ to place event markers on high-to-low transi-
tions of the Event input.

Event markers may also be placed in your data file manually by pressing the push button on the instrument. You must
enable Remote Events in WINDAQ to use the button (use the menu command Options > Remote Events +or Options
> Remote Events -).



An example event marker in a WINDAQ data file is shown below.

Event Marker*

2 WINDAQ - Hydr.. “lic Actuator Qualification.wdq
File Edit View Search g Transform XY Options Help
1000.0 ¢ TG .

psig | | N

ra
ow
@
ol L= ]

S S Sl ASHANG Y
_g 153 b i
IEASE 79.3660 SEC(TEF) 0816 SEC(TH) 62.4 ﬁOF T: .0080 SEC/DIV
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*Please Note: Event Markers do not display in the real-time WINDAQ acquisition software - they only display in the
WINDAQ playback software (WWB).

WINDAQ Remote Storage (D1 Record)

To use a switch closure or TTL signal to begin recording data remotely, connect signal leads to the appropriate
Remote Control Record terminals.

Once the switch closure or TTL signal is connected, activate Remote Storage (Record) through WINDAQ Acquisition
Software. Storage to Disk may be automatically placed on the rising or falling edge of the trigger signal. Use the
menu command Options > Remote Storage 1 to set WINDAQ to begin recording on low-to-high transitions of the
Record input. Use the menu command Options > Remote Storage 0 to set WINDAQ to begin recording on high-to-
low transitions of the Record input.

WINDAQ Rate (D2 Rate)

Enable channel 10 to record Rate, or the number of falling-edge transitions per unit of time that are applied to this
input. Click on Edit > Channels in the WINDAQ Acquisition menu to open the Channel Selection grid. Channel 10 is



the designated Rate channel. Click on the Channel 10 channel box to enable/disable Rates. The Channel 10 channel
box will display an “R” when enabled.

Channel Selection
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Click or press Space to enable (checlk) or disable.
Click or press I in column 9 to enable digital input.
Click or press B in column 10 to enable rate counter.
Click or press C in column 11 to enable reset counter.

0K Cancel

Connect any TTL pulse stream (25 VDC max) to the D2 Rate channel on the DI-4108 or DI-4208.

Select Channel 10 in the channel display, then select Edit > Channel Settings in the menu to specify a full scale
range for the Rate channel. Ranges of 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, 10000, 20000, and 50000 Hz are
available. Choose a range that comes closest to your expected full scale rate or frequency. For example, if you need to
measure the output of a flow meter that can measure a maximum flow rate of 100 gallons per minute, and the output
frequency at that rate is 100 Hz, you would choose the 100 Hz range setting. A range setting of 200 Hz full scale sac-



rifices half of the instrument's resolution at 200 gallons per minute, and a range of 50 Hz allows measurements to
only 50 gallons per minute full scale.

Gain -FS Hz +F5 Hz —hAcguisition Method -

50000.0
20000.0
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50.0  Frequency
20.0

10.0

—Input Type
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Filter Length = |1 " Nonlinear

" Thermocouple

™ Unipolar [~ Cycles!min

1].4 Reset EL Cancel

Previous

Check the "Cycles/min" box to display and select frequencies reported in cycles per minute instead of cycles per sec-
ond (the measurement interval remains the same). Tachometer measurements in units of RPM (revolutions per min-
ute) is just one example that benefits from selecting this option. For example, if the 100 Hz range setting is selected
and "Cycles/min" is checked, the full scale range is actually 6000 cycles per minute.

Please Note: To measure the maximum rate, which is defined as 2 times the Maximum Sample Rate/Channel , the cur-
rent values of Maximum Sample Rate/Channel divided by Sample Rate per Channel MUST be an integer.

WINDAQ Counter (D3 Count)
Enable channel 11 to record Counts, or the number of falling-edge transitions that are applied to this input. The count
may be reset via WINDAQ software or under program control as necessary. Click on Edit > Channels in the WINDAQ



Acquisition menu to open the Channel Selection grid. Channel 11 is the designated Count channel. Click on the
Channel 11 channel box to enable/disable Counts. The Channel 11 channel box will display a “C” when enabled.

Channel Selection
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CZlick or press Space to enable (check) or di=able.
Click or pres= I in column 9 to enable digital input.
CZlick or press R in column 10 to enable rate counter.
Click or pres= C in column 11 to enable re=et counter.

0K Cancel

The counter channel accumulates counts over time whether recording or in standby mode as soon as the Counter
channel is enabled. The accumulated values will be recorded to your data file unless you reset the counts to zero. The
maximum count value is 65,535 before the counter resets to zero automatically.

Use the Edit > Reset Count command in WINDAQ Acquisition software to reset counts immediately to zero. This
feature is available in both standby and record modes.

Use the Edit > Preferences > Reset Count on New File Record in WINDAQ Acquisition software to reset the count at
the start of a new file or when using the Edit > Preferences > Record Next File on Full or Open Next File on Full fea-
ture to reset counts to zero every time a new file is started.

Use the Edit > Preferences > Reset Count on Manual Record in WINDAQ Acquisition software to reset counts to
zero every time you begin or resume recording a data file using the File > Record command (F4).

Connect any TTL pulse stream (25 VDC max) to the D3 Count channel on the DI-4108 or DI-4208.



General Purpose Digital Inputs

Enable Channel 9 for general-purpose digital input functions. Click on Edit > Channels in the WINDAQ Acquisition
menu to open the Channel Selection grid. Channel 9 is the designated Digital Input channel. Click on the Channel 9
channel box to enable/disable the digital inputs. The Channel 9 channel box will display an “I”” when enabled.

Channel Selection
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Click or press Space to enable (check) or di=able.
Click or press I in column 9 to enable digital input.
Click or press E in column 10 to enable rate counter.
Click or press C in column 11 to enable reset counter.
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Channel 9 records and displays all the digital inputs, even the state of the Rate and Count inputs if those channels are
enabled. With Channel 9 selected in the display window click Scaling > Digital Plot to show a digital display and

make the data more meaningful on screen.



General Purpose Digital Outputs

Take care when configuring the load to be switched to ensure that the digital port is not damaged:

4-20mA Current Loop Measurements

Use the following diagram for 4-20mA current loop measurement connections.



The shunt resistor should be placed on the low side of the circuit as shown below:

Current Loop >< I + Loop Power
Transmitter 4-20mA T Supply

250Q
Shunt Resistor

+ -
v v
To DI-4108 or DI-4208
Analog Input Channel

Set the engineering units as desired and define upper/lower levels in WINDAQ as 1V = 4mA for the low value and 5V
= 20mA for the high value. For example, when using WINDAQ Acquisition software, in the EU Settings dialog box:

Channel 1 Engineering Unit Settings

Yolt EU EU Tag
Upper Lewvel ﬁ 5 =20
Lower Level ﬁ 1 F =
Previous ‘ 0K Next ‘ set Offset ‘ Cancel ‘

Enter the following values:

Volt | EU EU Tag

Upper Level 5 20
mA

Lower Level 1 4

Visit our website at http://www.dataq.com/blog/data-acquisition/4-20-ma-current-loop-measurements/ to address all
popular 4-20mA configurations.

You can also associate these values to a physical measurement such as pressure, load, flow, torque, etc. Read the Help
files for more information regarding Engineering Units Settings.



Mode LED Indicator

Indicates what mode the instrument is currently in. Use the chart on the top of the instrument for quick reference. Use
the table provided below for a more detailed description of each available state as well as a description of some states

not displayed on the label.

State Mode Description
Connecting The device is looking for a connection to your PC or USB thumb
O . drive. It will check the USB interface first, then the Ethernet and USB
thumb drive. Once a connection is established the device will enter
Blinking White Idle mode.
O . Idle The device is connected to and communicating with your PC through
USB Connected L}iz USB port. The USB thumb drive and Ethernet port are not accessi-
Blinking Green
O O Idle The device is connected to and communicating with your PC through
Ethernet or USB the E'thernet port or the device is in Stand-alone mode. The USB inter-
. face is not accessible.
Blinking Green/ Drive Connected
Yellow
Acquiring Data WinDaq Acquisition Software is running and the device is acquiring
. . to PC via USB data to your PC via the USB interface.
Blinking Blue | Interface
. O Acquiring Data WinDaq Acquisition Software is running and the device is acquiring
to PC via Ethernet data to your PC via the Ethernet interface.
Blinking Blue/ | Interface
Yellow
. O Recording Data The device is acquiring data and recording to your USB thumb drive.
to USB thumb Do got remove power - power interruption could result in data file cor-
o Dri ruption.
Blinking Blue/ rve
Green
Armed The device is acquiring data and waiting for a trigger condition to
. ( ) . begin recording to your USB thumb drive. Do not remove power or
.USB t humb Dr1v§ the USB thumb drive - either could result in data file corruption.
Blinking Blue/ is waiting for a trig-
Cyan ger condition
. . Re-armed The device is acquiring data and waiting for another trigger condition
. to continue recording to your USB thumb drive. Do not remove power
.USB t }.1umb Dr1v§ or the USB thumb drive - either could result in data file corruption.
Blinking Blue/ is waiting for a trig-
Cyan ger condition
Busy The device is reading from or writing to the USB thumb drive. Do not
. . USB thumb Drive remove power or the USB thumb drive - either could result in data file
s b corruption.
Blinking Red 1S busy




Error The device is unable to perform any operations. Cycle power or use
. the control button to resolve the error.

Solid Red
O Button Pushed The LED turns white to indicate the control button is engaged.
Solid White
Idle The device is connected to and communicating with your PC through
O . the USB port in CDC mode. WinDaq software will not run. The USB

USB connected in

thumb drive and Ethernet port are not accessible.
Blinking Yellow CDC mode

Control Button Operations

The Control Button can be used to stop or start recording data to the USB thumb drive when using the instrument as a
stand-alone data logger. The Control Button can also be used to reconfigure the instrument to factory default settings.
The Control Button can also be used to create an instantaneous event marker when running WINDAQ Acquisition
software.

Record Data to USB Thumb Drive

Record data to an installed USB thumb drive. The device must be in Idle mode and set for USB Drive (mode LED
must be flashing Green/Yellow). After the button is pressed, the mode LED will flash Blue/Green or Blue/Cyan to
indicate it is in a recording mode.

Stop Recording to USB Thumb Drive

Manually stop recording to the USB thumb drive (when the mode LED is flashing Blue/Green, Blue/Cyan, or Blue/
Magenta). After the button is pressed the mode LED will flash Green/Yellow to indicate Idle.

Fix Errors

The Control Button can also be used to fix some common operating errors. When the instrument is in Error mode
(mode LED is solid red), some action must be taken to fix the error before you can use it. Generally, the Control But-
ton can be used to make the instrument operational again when in Error mode.

Switching between LibUSB and CDC Modes

The native communication mode of DI-4108 and DI-4208 instruments is LibUSB but it can be switched to the USB
CDC (Communication Device Class). CDC mode allows the USB port of DI-4108 and DI-4208 devices to appear
like a traditional RS-232 port, which is common across most operating systems and development languages. Please
note: LibUSB communication is required for WinDaq Acquisition software and programming with our .NET SDK.
Only switch to CDC mode when writing your own programs at the protocol level (for example, Python applications).
Use the following sequence to switch your device to/from LibUSB/CDC modes:

1. Connect the device to your PC via the USB port.
2. Apply power to the device.

3. When mode LED stops blinking white and is in Idle mode, push and hold the Control button. This must be com-
pleted within five seconds after the device is in Idle mode.

4.  When the mode LED turns red, release the Control button.



5. The Mode LED will flash white then indicate Idle in either LibUSB or CDC mode:
e CDC mode: Blinking Yellow

e LibUSB mode: Blinking Green

Save Ethernet and Stand-alone configuration to Thumb Drive

Save Ethernet settings and/or stand-alone configuration settings using the Control Button. Ethernet and Stand-alone
configurations can also be saved to the thumb drive via the Dashboard (preferred method). Device must be in Idle
mode for Ethernet or USB thumb Drive (mode LED blinks green/yellow). The Unlock Code must be purchased for
your device in order to save the stand-alone configuration.

1. Format your USB thumb drive using your PC.

2. Confirm device is in Idle mode for USB Flash Drive (mode LED blinks Green/Yellow).

3. Push and hold the Control button.

4. Plug the formatted (empty) thumb drive into the device (Drive) while holding the button in.
5. Release the button when the mode LED changes to Red/Black.

6. The device will read and load the configuration files to the thumb drive and revert to Idle mode when complete.

Configuration files include network.json (Ethernet configuration) and config.whd or config.whc (WinDaq
configuration). Use the WinDaq Dashboard to create configuration files.

Apply Ethernet and Stand-alone Configuration to Device

Load Ethernet settings or stand-alone configuration settings using the Control Button. Ethernet and Stand-alone
configurations can also be applied via the Dashboard (preferred method). Device must be in Idle mode for Ethernet or
USB thumb Drive (mode LED blinks green/yellow). The Unlock Code must be purchased for your device in order to
apply the stand-alone configuration.

1. Save configuration files to your USB thumb drive.

2. Confirm device is in Idle mode for USB Flash Drive (mode LED blinks Green/Yellow).

3. Push and hold the Control button.

4. Plug the thumb drive into the device (Drive) while holding the button in.

5. Release the button when the mode LED changes to Red/Black.

6. The device will read and load the configuration files to the device and revert to Idle mode when complete.

Configuration files include network.json (Ethernet configuration) and config.whd or config.whc (WinDaq configura-
tion). Use the WinDaq Dashboard to create configuration files.

WinDaqg Dashboard

The WinDaq Dashboard allows you to run WinDaq Data Acquisition software, sync the device clock with your PC,
modify Ethernet settings, configure your instrument for stand-alone data logging to record data to a USB flash drive,
and access the USB thumb drive via the Ethernet interface. Devices in a ChannelStretch™ Group can synchronize



data recording in that group. Select all the devices under a ChannelStretch group and click on the Start WinDaq but-
ton. Stand-alone data logging is not available using ChannelStretch.

Configure  Help
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ChannelStretch™ Group
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Use the Configure menu to access the Stand alone setup window.

File

Analog Channel Setup Digital Channel Setup

M CH | Corfigwe | [] CH9 (Discrete)
[ cHz “orfigure L] CH1D (Rate) '!D!HDHZ v.

[(Jc3 [ Corfigure [] CH11 (Count)
[ cH4
[] cHs
[] CHe

] cH7
] cHe

File Storage Mode Sampling Interval
() Triggered mode

() Circular mode
(®) Non circular mode Selectable Range  6.25 psto 1000 s

[] Timed Storage

||ms w| 200 ssercn

File Storage Format
(@ WinDag format
() CSV format

Select and configure all channels available on your device, select a sampling interval, and setup recording Trigger
conditions. The Stand alone configuration also allows you to Save/Load configurations via the File menu. Use the
help file provided in WinDaq Dashboard to learn more. Please Note: You cannot record to the USB thumb drive while
the device is connected to your computer’s USB port.

ChannelStretch™

Expand the channel count of your DI-4718B with ChannelStretch. Both the DI-4718B-U and the DI-4718B-E can
synchronize with other USB devices via the USB interface. The DI-4718B-E can also synchronize with other
Ethernet instruments via the Ethernet interface. Connect up to 16 DI-4718B, DI-1120, DI-4108, and/or DI-4208
devices with a powered USB hub (or multiple cascaded/connected powered USB hubs) or Ethernet switch to record
more than 8 channels of data to a single WinDaq file. This provides a total of up to 128 analog channels and 112
digital ports at a maximum throughput rate of 480 kHz. Cascade multiple USB hubs or Ethernet switches to expand
port count. Synchronized instruments must have the same sample rate per channel, regardless of channel number,
type, or range. The WinDaq/Unlock option per instrument is required to synchronize two or more devices when
using WinDaq software.



Connection

All USB devices must be on the same USB controller (or hub)* in order to synchronize data acquisition. All Ethernet
devices must be on the same subnet as the PC that is recording the data (preferably the same Ethernet switch).

ChannelStretch™ Technology

to PC

16 units max
Max throughput = 480 kHz

Switch

to Power
as required

*Please Note: Because of the way Windows operating systems manage USB controllers, the only way to be absolutely
sure you are on the same controller is to use a powered USB hub.



Channel Selection

Devices are listed in the Channel Selection grid in alpha-numeric order of the serial numbers of the device. Devices
must be connected to the USB hub before starting WinDagq.

Channel Selection
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Click or press Space to enable (checlk) or disable.
Click or press I in column 9 to enable digital input.
Click or press B in column 10 to enable rate counter.
Click or press C in column 11 to enable reset counter.
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5. Unlock WinDag

The DI-4108M and DI-4208M will record up to eight channels using WinDag/Lite software and a single channel to
the USB thumb drive. An unlock code is required to use ChannelStretch™ to synchronize multiple instruments
(unlock code required for each unit to be synchronized). Go to https://www.dataq.com/products/di-4108/ or https://
www.dataq.com/products/di-4108/ to purchase either unlock code or call 330-668-1444. Once purchased, you will be
given a Key code to enter into WinDaq (for WinDag/Unlock) or the WinDaq Dashboard (for SA-Enabled).

WinDag/Unlock

Allows you to record more than four channels to WinDaq and unlocks ChannelStretch.

1. Start WinDaq Acquisition software.

2. Click the menu item Help > Unlock WinDagq.

To purchase WinDagfUnlock software, go to www.datag.com
or call DATAQ Instruments at 330-668-1444,

Serial#=  AD5B903IE
Key = | | | |

0K | Help | Cancell

3. Enter the Key in the appropriate dialog boxes.

4. Click OK.

SA-Enabled

Allows you to unlock all channels for stand-alone data logging as well as all the channels in WinDaq.

1. Start WinDaq Dashboard software.

2. Select your device and click the menu item Configure > Stand Alone Setup.

Stand-alone operation has not been enabled on this device. Please purchase and
apply an unlock code to enable this feature, Would you like to enter the code

now?

Unlock WinDaq
31



DI-4108M and DI-4208M Hardware Manual

3. Click on the Yes button to enter your code. Click on the No button to go to Stand-alone configuration for a single
channel.

Purchase the code to unlock Stand-slone operation (part number
S5A-Enabled) at www datag.com or call Dataq Instruments at
330-668-1444

Serial #= 5CBEDSZD

Key= |

4. Enter the Key in the appropriate dialog boxes.

5. Click OK.

Unlock WinDaq
32
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6. Dimensional Drawing
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